【AWS】aws cli コマンドをアップデート(update)する手順

aws cli コマンドをアップデート(update)する手順について解説します。

 

 

 

■現在のバージョン

[test@CentOS7 ~]$ aws --version
aws-cli/1.18.66 Python/2.7.5 Linux/3.10.0-1127.8.2.el7.x86_64 botocore/1.16.16
[test@CentOS7 ~]$

 

 

 

 

 

■aws cli アップデートコマンド実行

[root@CentOS7 ~]# pip install -U awscli

 

 

 

■aws cli アップデートコマンド実行例

[root@CentOS7 ~]# pip install -U awscli 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support 
Collecting awscli 
  Using cached awscli-1.18.93-py2.py3-none-any.whl (3.2 MB) 
Collecting botocore==1.17.16 
  Using cached botocore-1.17.16-py2.py3-none-any.whl (6.3 MB) 
Requirement already satisfied, skipping upgrade: colorama<0.4.4,>=0.2.5; python_version != "3.4" in /usr/lib/python2.7/site-packages (from awscli) (0.4.3) 
Requirement already satisfied, skipping upgrade: s3transfer<0.4.0,>=0.3.0 in /usr/lib/python2.7/site-packages (from awscli) (0.3.3) 
Requirement already satisfied, skipping upgrade: PyYAML<5.4,>=3.10; python_version != "3.4" in /usr/lib64/python2.7/site-packages (from awscli) (3.10) 
Requirement already satisfied, skipping upgrade: rsa<=3.5.0,>=3.1.2 in /usr/lib/python2.7/site-packages (from awscli) (3.4.2) 
Requirement already satisfied, skipping upgrade: docutils<0.16,>=0.10 in /usr/lib/python2.7/site-packages (from awscli) (0.15.2) 
Requirement already satisfied, skipping upgrade: python-dateutil<3.0.0,>=2.1 in /usr/lib/python2.7/site-packages (from botocore==1.17.16->awscli) (2.8.1) 
Requirement already satisfied, skipping upgrade: urllib3<1.26,>=1.20; python_version != "3.4" in /usr/lib/python2.7/site-packages (from botocore==1.17.16->awscli) (1.25.9) 
Requirement already satisfied, skipping upgrade: jmespath<1.0.0,>=0.7.1 in /usr/lib/python2.7/site-packages (from botocore==1.17.16->awscli) (0.10.0) 
Requirement already satisfied, skipping upgrade: futures<4.0.0,>=2.2.0; python_version == "2.7" in /usr/lib/python2.7/site-packages (from s3transfer<0.4.0,>=0.3.0->awscli) (3.3.0) 
Requirement already satisfied, skipping upgrade: pyasn1>=0.1.3 in /usr/lib/python2.7/site-packages (from rsa<=3.5.0,>=3.1.2->awscli) (0.4.8) 
Requirement already satisfied, skipping upgrade: six>=1.5 in /usr/lib/python2.7/site-packages (from python-dateutil<3.0.0,>=2.1->botocore==1.17.16->awscli) (1.9.0) 
Installing collected packages: botocore, awscli 
  Attempting uninstall: botocore 
    Found existing installation: botocore 1.16.16 
    Uninstalling botocore-1.16.16: 
      Successfully uninstalled botocore-1.16.16 
  Attempting uninstall: awscli 
    Found existing installation: awscli 1.18.66 
    Uninstalling awscli-1.18.66: 
      Successfully uninstalled awscli-1.18.66 
Successfully installed awscli-1.18.93 botocore-1.17.16 
[root@CentOS7 ~]#

 

 

 

[root@CentOS7 ~]# aws --version
aws-cli/1.18.93 Python/2.7.5 Linux/3.10.0-1127.8.2.el7.x86_64 botocore/1.17.16
[root@CentOS7 ~]#

 

 

 

 

Posted by 100%レンタルサーバーを使いこなすサイト管理人

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

AlphaOmega Captcha Medica  –  What Do You See?
     
 

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください